Sunday, November 13, 2016

[PL] Polarr instalacja na Fedorze

Polarr
Ostatnimi czasy szukałem jakiegoś przyjemnego narzędzia do prostej obróbki zdjęć, który będę mógł uruchomić na kilku różnych systemach. Po kilku zapytaniach google wyrzuciło link do programu Polarr. Aplikacji jest dość intuicyjna i stosunkowo przyjemna wizualnie. 

Wersja darmowa wystarcza do prostego i szybkiego kadrowania zdjęć lub zmian podstawowych efektów jak nasycenie kolorów, kontrast, itd. Jeśli ktoś chce wesprzeć twórców to za 9,90$ można zakupić licencje na trzy systemy. W wersji płatnej dodatkowo dostajemy kilka dodatkowych rzeczy: zestaw dodatkowych filtrów, zbiorczy eksport zdjęć i możliwość tworzenia własnych filtrów. 

Aplikacja jest dostępna dla  kilku rodzin systemów. Niestety dla Linuksa twórcy dostarczają tylko paczkę deb. Jednak można ją stosunkowo prosto uruchomić na Fedorze. W tym celu należy wykonać poniższe kroki: 
  • Zainstalować aplikację do rozpakowywania paczek deb. W moim przypadku z pomocą przyszedł alien, którego czasem używam do prostej konwersji paczek deb do rpm i vice versa. 
    • sudo dnf install alien
  • Pobrać ostatnia wersje programu: 
    • wget https://s3-us-west-2.amazonaws.com/polarrelectron/ubuntu/polarr_1.0.0-1_amd64.deb
  • Następnie rozpakowujemy paczkę
    • alien -g polarr_1.0.0-1_amd64.deb
  • Kopiujemy zawartość katalogu ./polarr-1.0.0.orig/usr/share do /usr/share:
    • cp -r ./polarr-1.0.0.orig/usr/share /usr/
  • Tworzymy link symboliczny w /usr/bin/:
    • ln -s /usr/share/polarr/Polarr /usr/bin/polarr
  • Teraz za pomocą komendy polarr możemy uruchomić edytor. 
Uwaga konwersja DEB na RPM za pomocą alien działa dobrze, jednak potem możecie napiotkać na problem braku zależności libffmpeg.so. Niestety doinstalowania odpowiednich paczek, które zawierały libffmpeg.so wyglądało różnie na kolejnych wersjach Fedory, dlatego wolałem ręczne skopiowanie binarek, tak by nie być uzależnionym od zmian w dodatkowych paczkach. Przy okazji bibliotek libffmpeg.so jest dołączona przez twórców w paczce.   


Poniżej prosty skrypt, który pozwala na instalacje ostatniej wersji polarr'a.

0 comments:

Post a Comment